Обновление Firebird. Red Hat 5. Прошу совет

Администирование клиентской и серверной части InterBase, Firebird, Yaffil. Настройка файла конфигурации и т.п.

Модераторы: kdv, Alexey Kovyazin

Ответить
nbura
Сообщения: 11
Зарегистрирован: 05 сен 2011, 14:59

Обновление Firebird. Red Hat 5. Прошу совет

Сообщение nbura » 18 ноя 2011, 12:25

Есть сервер с Red Hat 5 на HP ML350, с которым я на "ВЫ" почти полностью. Поэтому хочу спросить совета здесь, чтобы не было потом...

Сейчас стоит FirebirdSS-2.1.1.17910-0 с 2008 года. Проблемы начались в последнее время, не буду в них углубляться, потому что часть CORE-файлов указывает на необходимость обновить версию.

Буду ставить FirebirdSS-2.5.1.26351-0.
Вопрос 1: нужно ли удалять сначала версию 2,1 или нужно ставить в режиме обновления или просто ставить поверх?
Вопрос 2: после установки, секьюрити2 можно просто перекопировать из старой версии или еще что-то?
Вопрос 3: после установки базу можно просто открыть, или лучше бекап-ресторе? (вопрос только в том, что ресторе пол дня проходит, боюсь не успеть)

И как мне лучше подстраховаться, чтобы не остаться совсем без файрберда? Спасибо.

dimitr
Разработчик Firebird
Сообщения: 888
Зарегистрирован: 26 окт 2004, 16:20

Re: Обновление Firebird. Red Hat 5. Прошу совет

Сообщение dimitr » 18 ноя 2011, 13:28

я бы для начала рассмотрел вопрос перехода на 2.1.4. В этом случае вопросы 1-3 отпадают. А уж если упомянутые проблемы останутся, тогда думать о 2.5.1.

Для 2.5.х:

1. лучше удалить и поставить с нуля. Перед удалением сделать бекап security2.fdb и основной базы.
2. можно, но лучше бекап-рестор. Иначе возможны проблемы.
3. аналогично предыдущему

hvlad
Разработчик Firebird
Сообщения: 1244
Зарегистрирован: 21 мар 2005, 10:48
Контактная информация:

Re: Обновление Firebird. Red Hat 5. Прошу совет

Сообщение hvlad » 18 ноя 2011, 13:59

Боюсь, в RH5 слишком старое ядро и\или glibc для нормальной работы 2.5 ...

nbura
Сообщения: 11
Зарегистрирован: 05 сен 2011, 14:59

Re: Обновление Firebird. Red Hat 5. Прошу совет

Сообщение nbura » 18 ноя 2011, 14:13

наверное Вы правы, прислушаюсь к совету насчет 2,1,4. К тому же те коре, по которым я нашел описания, фиксились и в 2,5 и в 2,1,4 тоже.

мне вообще кажется, что у меня проблема не сколько в версии, сколько в том, что файрберд сам мог уже "испортиться" и скорее важен сам факт переустановки, а не версия. (Может быть это бред, но это мое мнение как виндузятника - "взять да переустановить че нить", может быть в линуксе нет таких заморочек)

"В этом случае вопросы 1-3 отпадают" - извиняюсь, но с первым вопросом все таки как лучше? удалить или просто поверх поставить или обновить при установке?

dimitr
Разработчик Firebird
Сообщения: 888
Зарегистрирован: 26 окт 2004, 16:20

Re: Обновление Firebird. Red Hat 5. Прошу совет

Сообщение dimitr » 18 ноя 2011, 14:55

nbura писал(а):"В этом случае вопросы 1-3 отпадают" - извиняюсь, но с первым вопросом все таки как лучше? удалить или просто поверх поставить или обновить при установке?
да все равно. Если у пакета есть возможность "обновить", тогда лучше так.

nbura
Сообщения: 11
Зарегистрирован: 05 сен 2011, 14:59

Re: Обновление Firebird. Red Hat 5. Прошу совет

Сообщение nbura » 18 ноя 2011, 15:08

как говорит Лобанов, вот вы мне сейчас совсем ничего не разьяснили :lol:
я в Линуксе баран на 98%, мне не понять, может ли пакет сам обновляться или нет. Я прочитал 2-3 статьи про RPM и имею в сиду только ключи -i и -u или -f

Но по большому счету это все пустословие с моей стороны, я думаю особой роли это не сыграет, попробую сначала удалить старый, потом поставить новый.
П.С. На соседнюю файлопомойку на АльтЛинуксе для пробы поставил версию 2,5, вроде удачно, можно сказать лишился пакетной девственности.

Dimitry Sibiryakov
Заслуженный разработчик
Сообщения: 1427
Зарегистрирован: 15 сен 2005, 09:05
Откуда: Krupka
Контактная информация:

Re: Обновление Firebird. Red Hat 5. Прошу совет

Сообщение Dimitry Sibiryakov » 18 ноя 2011, 15:49

dimitr писал(а):Если у пакета есть возможность "обновить", тогда лучше так.
Вроде бы везде давно писалось, что RPM-пакет Firebird обновляться не умеет...

nbura
Сообщения: 11
Зарегистрирован: 05 сен 2011, 14:59

Re: Обновление Firebird. Red Hat 5. Прошу совет

Сообщение nbura » 21 ноя 2011, 12:23

обновление с 2.1.1 на 2.1.4 прошло успешно, базу заресторил-забекапил. Но, поймал один интересный , но неприятный момент.
В версии 2.1.1 в запросах иногда использовал "+0" к условию связи, для замены дефолтного индекса другим, более рациональным в этом запросе , пример:

Код: Выделить всё

select count(d.rec_id)
    from rs_detali d
      join rs_mat_set ms on ms.mat_cod+0 = d.id_mater
      join rs_group_options gr on gr.gr_id = ms.rs_group and gr.rs_tip = 1
    where d.id_part = :P
В версии 2.1.4 все запросы с "+0" стали считаться не с другим индексом, а вообще без индексов. Удаление "+0" дает конечно правильную оптимизацию плана запроса автоматом, но приходиться авралом переделывать кучу запросов в куче приложений, хранимок, отчетных квериках.

Вопрос - это особенность смены версии на 2.1.4, или я какой-то не тот сервер поставил, вроде и старый и этот были супер серверы.

Каких еще сюрпризов такого плана можно ожидать?

П.С. Вроде при быстром просмотре "Что нового" не заметил этой особенности, может не так прочитал

dimitr
Разработчик Firebird
Сообщения: 888
Зарегистрирован: 26 окт 2004, 16:20

Re: Обновление Firebird. Red Hat 5. Прошу совет

Сообщение dimitr » 21 ноя 2011, 12:28

nbura писал(а):Вопрос - это особенность смены версии на 2.1.4
да. Оптимизатор меняется в каждом релизе, такие эффекты вполне возможны.

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость