Может ли клиент от IB работать с сервером с FB?

Совместимость InterBase, Firebird, Yaffil между собой и по версиям

Модераторы: kdv, Alexey Kovyazin

Ответить
Начинающий
Сообщения: 5
Зарегистрирован: 05 ноя 2007, 10:42

Может ли клиент от IB работать с сервером с FB?

Сообщение Начинающий » 05 ноя 2007, 10:53

Может ли клиент от IB работать с сервером с FB? А наоборот?
Если да, то зависит ли это от версий?

kdv
Forum Admin
Сообщения: 6575
Зарегистрирован: 25 окт 2004, 18:07
Контактная информация:

Сообщение kdv » 05 ноя 2007, 12:06

именно так. может, зависит от версий.

Начинающий
Сообщения: 5
Зарегистрирован: 05 ноя 2007, 10:42

Сообщение Начинающий » 05 ноя 2007, 19:06

Какие клиенты IB могут работать с сервером FB 1.5.1.4481, IB и FB с серверами IB 6.x?

kdv
Forum Admin
Сообщения: 6575
Зарегистрирован: 25 окт 2004, 18:07
Контактная информация:

Сообщение kdv » 05 ноя 2007, 23:10

Какие клиенты IB могут работать с сервером FB 1.5.1.4481, IB и FB с серверами IB 6.x?
я могу выполнить такое исследование, баксов за 200 (без шуток, у меня есть все серверы и клиенты, за полдня могу управиться). Правда, если чуть уточнить задание:

1. требуется проверить только клиентов IB? или и FB тоже? Начиная откуда - от 4.x ?
2. зачем в списке серверы IB 6.x ? т.е. кому нужен этот древний отстой?
3. почему в списке именно FB 1.5.1?

kdv
Forum Admin
Сообщения: 6575
Зарегистрирован: 25 окт 2004, 18:07
Контактная информация:

Сообщение kdv » 07 ноя 2007, 00:33

ау, 200 баксов мне за исследование обломится, или забить? :)

Dimitry Sibiryakov
Заслуженный разработчик
Сообщения: 1427
Зарегистрирован: 15 сен 2005, 09:05
Откуда: Krupka
Контактная информация:

Сообщение Dimitry Sibiryakov » 07 ноя 2007, 10:06

Я ответ знаю, но зачем же лишать хорошего человека куска хлеба с маслом...

Начинающий
Сообщения: 5
Зарегистрирован: 05 ноя 2007, 10:42

Сообщение Начинающий » 07 ноя 2007, 10:18

Вопрос частично решен.
Кто может сказать БЕСПЛАТНО что-нибудь по поводу совместимости клиентов IB 6.0.1.0/6.5.0.5/6.5.0.28 с сервером FB 1.5.3.4870?

Начинающий
Сообщения: 5
Зарегистрирован: 05 ноя 2007, 10:42

Сообщение Начинающий » 07 ноя 2007, 10:20

kdv писал(а):ау, 200 баксов мне за исследование обломится, или забить? :)
К сожалению, придется обломиться...

WildSery
Заслуженный разработчик
Сообщения: 1738
Зарегистрирован: 05 июн 2006, 16:19

Сообщение WildSery » 07 ноя 2007, 10:49

Начинающий писал(а):Кто может сказать БЕСПЛАТНО что-нибудь по поводу совместимости клиентов IB 6.0.1.0/6.5.0.5/6.5.0.28 с сервером FB 1.5.3.4870?
Скорее всего, работать будет. (только в Windows, в линуксе скорее всего нет).
Только такие исследования вот никому нафиг не упали. Тянут на Шнобелевскую премию, пожалуй.

kdv
Forum Admin
Сообщения: 6575
Зарегистрирован: 25 окт 2004, 18:07
Контактная информация:

Сообщение kdv » 07 ноя 2007, 19:22

по поводу совместимости клиентов IB 6.0.1.0/6.5.0.5/6.5.0.28 с сервером FB 1.5.3.4870?
чего вы хотите-то, объясните внятно. В сети крутятся несколько разных серверов? Аццкий отстой 6.0.1.0, глюкало 6.5.0.5 и средний 6.5.0.28 ?
http://www.ibase.ru/devinfo/allversions.htm

Есть приложения, которым нужен 6.0, а другим FB 1.5 ?
Если да, то какая проблема - кидайте клиентскую часть gds32.dll/fbclient РЯДОМ с exe, и не будет никаких проблем.
А так чтобы гарантированно клиент 1.5 работал с этими старыми версиями - это фантастика. Т.е. работать-то он будет, но за отсутствие глюков никто не поручится.
К сожалению, придется обломиться...
мне обломиться не получится :) Я ответ знаю или не знаю, но могу проверить. А Вы - нет. Вы используете 6.0/6.5 - а я их только для ремонта и вопросов совместимости держу. И т.д.

Начинающий
Сообщения: 5
Зарегистрирован: 05 ноя 2007, 10:42

Сообщение Начинающий » 08 ноя 2007, 07:37

Ясно.

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя