Совместимость FB 2.0 и 1.5 на уровне бэкапа

Совместимость InterBase, Firebird, Yaffil между собой и по версиям

Модераторы: kdv, Alexey Kovyazin

Dimitry Sibiryakov
Заслуженный разработчик
Сообщения: 1427
Зарегистрирован: 15 сен 2005, 09:05
Откуда: Krupka
Контактная информация:

Сообщение Dimitry Sibiryakov » 09 мар 2006, 08:36

dimitr писал(а):умеет, но реализация транспорта несовместима с 1.x
Правильно. Потому-то она и называется XNET. Чтобы не путали.

slisebo
Сообщения: 4
Зарегистрирован: 21 дек 2005, 15:34

Re: Совместимость FB 2.0 и 1.5 на уровне бэкапа

Сообщение slisebo » 05 фев 2009, 12:16

ну и как все-таки восстановить на 1.5 бэкап от fb2.1 ?

Dimitry Sibiryakov
Заслуженный разработчик
Сообщения: 1427
Зарегистрирован: 15 сен 2005, 09:05
Откуда: Krupka
Контактная информация:

Re: Совместимость FB 2.0 и 1.5 на уровне бэкапа

Сообщение Dimitry Sibiryakov » 05 фев 2009, 13:30

Никак, обломись.

dimitr
Разработчик Firebird
Сообщения: 888
Зарегистрирован: 26 окт 2004, 16:20

Re: Совместимость FB 2.0 и 1.5 на уровне бэкапа

Сообщение dimitr » 05 фев 2009, 22:51

теоретически, если gbak-ом от 2.1 ресторить на сервер 1.5, то фокус может и пройти...

kdv
Forum Admin
Сообщения: 6575
Зарегистрирован: 25 окт 2004, 18:07
Контактная информация:

Re: Совместимость FB 2.0 и 1.5 на уровне бэкапа

Сообщение kdv » 05 фев 2009, 23:42

ну и как все-таки восстановить на 1.5 бэкап от fb2.1 ?
каком. тут написано
http://www.ibase.ru/devinfo/prevver.htm
в топике уже объяснялось, что если база создана и разработана в ФБ 2.1, то никак БЭКАПОМ базу не перенести на 1.5. Можно только скриптом, и то если не использовалось то, что есть в 2.1 и нет в 1.5. Не умеет 1.5 понимать фишек 2.1. Не бывает вообще совместимости сверху вниз. Бывает, только если ПО не меняется от версии к версии. Чего тоже практически не бывает.

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя